502 Error When Accessing Blend Beta Environments

Incident Report for Blend

Resolved

The issue impacting Blend Beta environments has been resolved, and the beta environments are now functioning normally.

We will continue to monitor closely to ensure ongoing stability. Please feel free to reach out to us if you encounter any issues.

Thank you for your patience while we worked through this issue.
Posted Apr 09, 2026 - 20:07 UTC

Update

The issue impacting Blend Beta environments has been resolved, and the beta environments are now functioning normally.

We will continue to monitor closely to ensure ongoing stability. Please feel free to reach out to us if you encounter any issues.

Thank you for your patience while we worked through this issue.
Posted Apr 09, 2026 - 20:06 UTC

Update

We are continuing to investigate the issue impacting access to Blend Beta environments. We believe we have identified the root cause, but are currently validating. Users may continue to encounter a 502 error when attempting to access these environments.

Our team is actively validating the resolution to the root cause impacting Beta environments. At this time, we can confirm that only Beta environments were affected but we are continuing to monitor things and will provide more updates as they become available.
Posted Apr 09, 2026 - 18:27 UTC

Update

We are continuing to investigate this issue.
Posted Apr 09, 2026 - 16:32 UTC

Investigating

We are currently investigating an issue impacting access to Blend Beta environments. Users may encounter a 502 error when attempting to access these environments.

Our team is actively working with engineering to identify the root cause and restore normal functionality. We will provide updates as more information becomes available.
Posted Apr 09, 2026 - 16:26 UTC
This incident affected: Lending Platform.