Service with eOriginal

Incident Report for Blend

Resolved

The recent eOriginal outage has been resolved. You can now send packages with eNotes, and borrowers are able to sign eNotes as expected.
If you experience any further issues, please contact us at support@blendclose.com
Posted Jul 02, 2025 - 21:00 UTC

Monitoring

We are currently experiencing an interruption in service with eOriginal. This outage is preventing successful eNote operations at this time. If you are actively attempting to send an eNote or an eNote is not able to be signed for same day closings, we recommend papering these out. Our team is actively monitoring the situation and is in communication with eOriginal.
Posted Jul 02, 2025 - 20:04 UTC
This incident affected: Lending Platform.