Blend External API

Incident Report for Blend

Resolved

We identified and reverted a configuration change that was causing request failures for a subset of Blend-managed integration connectors. All connectors are now processing normally, and core Blend application functionality was unaffected throughout. We are reviewing any events that were impacted during this window and will retry those as needed. If you have questions about specific transactions, please reach out to your Blend contact.
Posted Sep 07, 2026 - 13:01 PDT

Update

We've identified the cause of errors affecting a subset of Blend-managed integration connectors. Affected customers may experience failures in loan data exports, document transfer between Blend and the LOS, and inbound LOS event delivery that updates records in Blend.
Core Blend application functionality and the majority of integrations remain unaffected. Our engineering team is actively working on remediation.
Posted Sep 07, 2026 - 11:46 PDT

Update

We've narrowed the issue to a subset of Blend-managed integration connectors. Affected customers may experience failures in loan imports, document generation, disclosure delivery, and closing workflows that depend on these integrations. Most integrations and all core Blend application functionality are operating normally.
Our engineering team is working to mitigate the failures and restore the service.
Posted Sep 07, 2026 - 10:58 PDT

Investigating

We're investigating elevated error rates on Blend's external API (api.blendlabs.com). Some API requests from partner and vendor integrations are failing or completing only after retries and delays. This may impact integration-driven workflows, including document generation and loan exports to your LOS. The core Blend application is operating normally.
Our engineering team is actively investigating and we'll post an update as soon as we have more information.
Posted Sep 07, 2026 - 09:59 PDT
This incident affected: LOS Integrations and Disclosures and Documents.