Salesforce performance degradation

Incident Report for Blend

Resolved

This incident has been resolved.
Posted Oct 01, 2024 - 21:02 UTC

Monitoring

Salesforce updates are not flowing through for a subset of customers due to a performance degradation incident in Salesforce systems. We are currently monitoring the situation and will provide an update on the next steps once the incident is resolved within Salesforce.
Posted Oct 01, 2024 - 16:38 UTC
This incident affected: Connectivity.