Blend - Unable to Access

Incident Report for Blend

Resolved

All affected services including Blend Signing Room (RONs) and Public API have been recovered.
Posted Jan 13, 2026 - 21:52 UTC

Update

We are seeing signs of recovery of Blend Platform logins (email and SSO). Our Engineering team remains actively engaged and continues to investigate Blend Signing Room (RONs) and other affected services. We will share additional updates as more information becomes available.
Posted Jan 13, 2026 - 21:22 UTC

Update

We are seeing signs of improvement across impacted services. Our Engineering team remains actively engaged and continues to investigate the root cause. We will share additional updates as more information becomes available.
Posted Jan 13, 2026 - 21:01 UTC

Update

We are aware of an issue impacting all logins (email and SSO), application creation, eClose, and disclosures. Our team is actively investigating the root cause and will provide updates as more information becomes available.
Posted Jan 13, 2026 - 20:45 UTC

Investigating

We are aware of an issue currently impacting all logins(emails and SSO), app creation, eClose, disclosures, and are actively investigating the root cause.
Posted Jan 13, 2026 - 20:23 UTC
This incident affected: Lending Platform.