eSign Outage
Incident Report for Blend
Resolved
We are no longer seeing latencies. All eSign related services are now fully operational.
Posted Sep 13, 2024 - 16:06 UTC
Update
We have identified the root cause of high latencies with one of our e-sign providers. The latencies started to improve around 8:21 am PST, and we are now seeing package creation flows and e-sign success rates returning to normal. We are actively monitoring the recovery progress and anticipate being fully operational soon.
Posted Sep 13, 2024 - 15:55 UTC
Monitoring
We have identified the root cause of high latencies with one of our e-sign providers. The latencies started to improve around 8:21 am PST, and we are now seeing package creation flows and e-sign success rates returning to normal. We are actively monitoring the recovery progress and anticipate being fully operational soon.
Posted Sep 13, 2024 - 15:54 UTC
Investigating
We are experiencing degradation related to services that need eSign.
Posted Sep 13, 2024 - 15:27 UTC
This incident affected: Lending Platform and LOS Integrations.