Disclosures and Close functionality unavailable
Incident Report for Blend
Resolved
All disclosures and close delivery functionality has been restored. Blend support will notify impacted clients about reconciling affected packages.
Posted Jul 21, 2023 - 23:14 UTC
Investigating
Blend is currently experiencing an outage affecting Disclosures and Close services. Issuing new disclosures and close packages, as well as retrieving fully executed packages will be unavailable until the issue is resolved. Additional updates will be relayed here as the root cause is identified.
Posted Jul 21, 2023 - 22:51 UTC
This incident affected: Lending Platform.