eNote Issue - eOriginal

Incident Report for Blend

Resolved

This incident has been resolved. Users who attempted to generate or sign an eNote but weren't able to, please try again now.
Posted Jun 18, 2025 - 20:58 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 18, 2025 - 20:48 UTC

Update

We are continuing to investigate this issue.
Posted Jun 18, 2025 - 19:23 UTC

Investigating

We're currently experiencing an interruption in service with one of our eNote vendors, eOriginal. This outage is preventing successful eNote operations at this time. Our team is actively monitoring the situation and is in communication with eOriginal. We will post further updates here as soon as we have more information. Thank you for your patience.
Posted Jun 18, 2025 - 19:10 UTC
This incident affected: Lending Platform.