Google Captcha error during user account creation
Incident Report for Blend
Resolved
Google Recaptcha has been fixed and re-enabled for all customers who had it enabled previously.
Posted Jan 13, 2025 - 22:00 UTC
Update
Google Recaptcha has been fixed and re-enabled for all customers who had it enabled previously.
Posted Jan 13, 2025 - 21:58 UTC
Update
The issue is currently mitigated through temporarily disabling Google Recaptcha where enabled.
Posted Jan 13, 2025 - 20:23 UTC
Investigating
We are investigating an issue that is affecting new borrower account creation due to issues with Google Recaptcha. This appears to only be affecting customers who have Google Recaptcha enabled.
Posted Jan 13, 2025 - 20:21 UTC
This incident affected: Lending Platform.