Major Amazon Web Services (AWS) Outage

Incident Report for Blend

Resolved

Our application export queues have returned to normal levels. At this time, we believe that this incident is resolved, although some of Blend's integration partners may continue to experience issues as they recover.
Posted Oct 20, 2025 - 21:37 UTC

Monitoring

We have recovered our baseline infrastructure capacity, and the Blend platform is now fully available. System performance has stabilized, and latencies have returned to normal levels.

We are currently processing a backlog of loan applications that accumulated during the disruption and will provide an update once that backlog has been fully cleared.

Thank you for your patience and understanding as we worked through this issue.
Posted Oct 20, 2025 - 21:11 UTC

Update

We have recovered our baseline infrastructure capacity, and the Blend platform is now fully available. System performance has stabilized, and latencies have returned to normal levels.

We are currently processing a backlog of loan applications that accumulated during the disruption and will provide an update once that backlog has been fully cleared.

Thank you for your patience and understanding as we worked through this issue.
Posted Oct 20, 2025 - 21:06 UTC

Update

We wanted to provide you with the latest update regarding the ongoing service disruption. AWS has identified the root cause and is actively deploying a solution to restore compute resource availability.

To mitigate the impact during this period, our engineering team strategically reallocated available resources to prioritize critical functions, such as application submission. While this ensured the stability of core services, it may have temporarily affected performance in other areas of the platform.

We are beginning to see signs of recovery as the AWS fixes are rolled out. While service may be intermittent over the next couple of hours, AWS anticipates the deployment will be complete within approximately two hours, at which point we expect a full restoration of service.
Posted Oct 20, 2025 - 19:07 UTC

Identified

AWS continues to experience issues in the US-EAST-1 region and is actively working to deploy a fix within the next few hours.
Blend’s internal teams are continuing to monitor the situation closely and are exploring the option of cutting over to another fully functional AWS region. However, this decision involves a number of considerations — including the potential risks of data loss, impact to currently unaffected clients, and overall recovery stability.

We are handling this situation with the utmost care to ensure that any action taken is safe, deliberate, and in the best interest of all clients.

Please continue monitoring our status page as well as the AWS Status Page https://health.aws.amazon.com/health/status for updates.
Posted Oct 20, 2025 - 17:38 UTC

Update

While Blend has been able to recover some services, we are proceeding carefully and have not immediately enacted our disaster recovery process.

This decision is intentional — cross-region disaster recovery is a complex process that carries potential risks, including data loss, impact to unaffected clients, and the possibility of slowing overall recovery for those already stabilizing.

Our engineering teams are closely monitoring AWS’s progress and Blend’s own platform stability to ensure that any action we take fully protects client data and minimizes disruption. Once we have confidence in a stable recovery path, we will take any necessary next steps to restore full service safely and efficiently.
Posted Oct 20, 2025 - 16:35 UTC

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 15:27 UTC

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 14:37 UTC

Investigating

We continue to see infrastructure-related issues which continue to have an impact on the availability and performance of the Blend platform. We will update this status page at a regular interval or when we see consistent recovery across the platform.
Posted Oct 20, 2025 - 14:37 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 10:51 UTC

Monitoring

We are seeing Blend services recover from the disruption and continue to monitor.
Posted Oct 20, 2025 - 10:44 UTC

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 09:30 UTC

Investigating

A major Amazon Web Services (AWS) outage is causing widespread internet disruptions, impacting multiple apps and services, including Blend. We are continuing to investigate this issue.
Posted Oct 20, 2025 - 09:27 UTC
This incident affected: Lending Platform, LOS Integrations, and Lending Platform.