eClose - Hybrid Closing Packages (manually tagged only)

Incident Report for Blend

Resolved

Resolved but still monitoring. Continue to send Hybrid Closing packages.
Posted Feb 11, 2026 - 17:05 UTC

Investigating

We are currently experiencing processing delays with manually tagged Hybrid closing packages. Our engineering team is actively investigating the root cause to restore normal processing speeds. In the meantime, we recommend sending closing packages as Traditional.
Posted Feb 11, 2026 - 15:50 UTC
This incident affected: Blend Close.