DocuSign Outage

Incident Report for Blend

Resolved

This incident has been resolved.
Posted Feb 05, 2025 - 20:37 UTC

Monitoring

Blend has been notified of an outage with our partner, Docusign, affecting most availability of eSigning within Blend that is utilizing Docusign. Blend is monitoring the recovery and will share updates when available. Borrowers who have been sent documents to eSign in a Docusign envelope will be unable to eSign throughout the outage.
Posted Feb 05, 2025 - 19:34 UTC
This incident affected: Lending Platform.