Blend Income
Incident Report for Blend
Resolved
This incident has been resolved.
Posted Jul 27, 2022 - 22:30 UTC
Monitoring
We have deployed a hotfix as of 5:40pm ET and are monitoring the situation for improvement.
Posted Jul 27, 2022 - 21:52 UTC
Identified
As of 3:20pm ET, Blend discovered an issue with the Blend Income service.

We are promptly investigating the underlying cause and have disabled Blend Income in the meantime.
Posted Jul 27, 2022 - 20:43 UTC
This incident affected: Connectivity.