Platform Availability
Incident Report for Blend
Resolved
This incident has been resolved. Access to the Blend portal is confirmed to be working but some tasks may experience delays as our systems recover.
Posted Jul 29, 2022 - 18:22 UTC
Investigating
We are currently aware of an issue with accessing Blend and are investigating immediately.
Posted Jul 29, 2022 - 17:47 UTC
This incident affected: Lending Platform.