Docutech Outage

Incident Report for Blend

Resolved

This incident has been resolved.
Posted 1 year ago. Apr 19, 2024 - 20:50 UTC

Monitoring

We are starting to see successful traffic again and are monitoring closely with our partners at Docutech.
Posted 1 year ago. Apr 19, 2024 - 20:23 UTC

Update

We are continuing to work with our partners at Docutech towards a resolution of this issue, we will provide another update as soon as it is available.
Posted 1 year ago. Apr 19, 2024 - 19:21 UTC

Update

We have engaged Docutech who are now aware of the issue and are opening an investigation on their end. At this time all Disclosures, Hybrid, and RON closings that are utilizing Docutech are affected; traditional paper closings are unaffected.
Posted 1 year ago. Apr 19, 2024 - 15:31 UTC

Investigating

We are experiencing an integrations outage between Blend and our partner Docutech. At this time all Disclosures, Hybrid, and RON closings are affected. Traditional paper closings are unaffected. We have engaged with out partner and will continue to post updates as the situation progresses.
Posted 1 year ago. Apr 19, 2024 - 15:00 UTC
This incident affected: Lending Platform.