EClose Error
Incident Report for Blend
Resolved
This incident has been resolved and there was very minimal impact.
Posted Mar 28, 2023 - 21:43 UTC
Investigating
Blend has identified an issue impacting loans that have issued e-close packages from 6:30 am PST 3/28/23. Our team is diligently working to resolve. We will continue to investigate and relay updates as soon as they become available.
Posted Mar 28, 2023 - 19:58 UTC
This incident affected: Lending Platform.