Twilio outage

Incident Report for Blend

Resolved

The issue affecting delivery of multi-factor authentication codes sent via SMS short code appears to be resolved. Service has recovered, and users should now be able to receive MFA codes as expected.
Posted Jun 22, 2026 - 19:57 UTC

Update

Twilio has observed a recovery in SMS delivery from a subset of Twilio Short Codes to network subscribers on multiple networks in the United States and are monitoring service stability. Twilio will provide another update in 2 hours or as soon as more information becomes available.
Posted Jun 22, 2026 - 17:33 UTC

Monitoring

We have confirmed an issue affecting delivery of multi-factor authentication codes sent via SMS short code. Twilio has also reported this outage on their status page, https://status.twilio.com/. Some users may experience delays receiving their authentication code or may not receive it at all.
Posted Jun 22, 2026 - 16:37 UTC