We're continuing to monitor the integration between TotalExpert and Blend. Our teams remain in close contact and are reviewing additional data together as part of the ongoing investigation. Clients are encouraged to also monitor TotalExpert's status page (status.totalexpert.com) for updates from their end. We will provide a further update if there's a material change or new information becomes available.
Posted Sep 04, 2026 - 18:17 PDT
Update
We're continuing to see improvement in the integration between TotalExpert and Blend and remain in close contact with TotalExpert as we work toward a full resolution. We will provide a further update as new information becomes available.
Posted Sep 04, 2026 - 15:41 PDT
Update
We are seeing signs of recovering. Our team is currently monitoring the stability of the integration between TotalExpert and Blend and we have not seen event failures for the past 60 mins. We will provide further updates as new information becomes available.
Posted Sep 04, 2026 - 15:01 PDT
Monitoring
We are currently experiencing connectivity issues affecting the integration between TotalExpert and Blend. TotalExpert's webhook endpoint is currently returning a 503 "Service Temporarily Unavailable" response when Blend attempts to deliver webhook events. We apologize for any inconvenience this may cause and will provide further updates as new information becomes available.