Lender users unable to complete DocuSign Esign tasks
Incident Report for Blend
Resolved
We have successfully deployed a solution to this issue and DocuSign eSign tasks should be unblocked at this time. After a refresh of the Blend website, eSign tasks should again be functioning properly for all users.
Posted Dec 14, 2023 - 20:57 UTC
Identified
We have identified the issue with the outstanding DocuSign task incident and are currently testing a potential fix. We plan to update and release as soon as a solution can be validated.
Posted Dec 14, 2023 - 20:34 UTC
Investigating
Esign tasks for lender users utilizing DocuSign are experiencing an outage. Any disclosures or closings requiring lender user signatures using DocuSign will not be able to be completed until the outage is resolved. We’re investigating the cause of the issue currently.
Posted Dec 14, 2023 - 16:43 UTC
This incident affected: Lending Platform.