Docusign Performance Degradation
Incident Report for Blend
Resolved
This incident has been resolved.
Posted Apr 30, 2024 - 19:04 UTC
Monitoring
DocuSign latency times are starting to show signs of recovery. We are still monitoring closely for confirmation on fully restored functionality
Posted Apr 30, 2024 - 16:29 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 30, 2024 - 15:32 UTC
Identified
Blend has been made aware of a Docusign Performance Degradation that could impact the ability to issue disclosures, closings, follow-ups, and potentially any workflow that uses the eSign functionality.
Posted Apr 30, 2024 - 15:30 UTC