Blend is experiencing service degradation due to ongoing issues with our cloud hosting provider.
Incident Report for Blend
Resolved
The Blend lending platform has returned to a normal operating state. This incident has been resolved.
Posted Jun 13, 2023 - 22:26 UTC
Monitoring
The Blend lending platform has returned to a normal operating state. All Impacted services have since been recovered minus our Document which is currently recovering. Once the Document service is fully recovered we will update this status to Resolved.
Posted Jun 13, 2023 - 21:56 UTC
Identified
We have started seeing service recovery, although we’re still experiencing increased error rates across the Blend lending platform.
Posted Jun 13, 2023 - 21:01 UTC
Investigating
Blend is experiencing service degradation due to an issue with our cloud hosting provider. We are actively investigating the impact and will post an update when we know more.
Posted Jun 13, 2023 - 19:43 UTC
This incident affected: Lending Platform.