Velocify Lead Creation Issue

Incident Report for Blend

Resolved

This has now been resolved by ICE and we are seeing leads being created at a normal rate.
Posted May 23, 2025 - 16:31 UTC

Investigating

Velocify is reporting the same issue as last night and we are seeing a high number of lead creation errors. Here is a link to their status page for further information: https://emstatuscenter.elliemae.com/
Posted May 23, 2025 - 15:48 UTC
This incident affected: LOS Integrations.