Document signing functionality unavailable
Incident Report for Blend
Resolved
This incident has been resolved and all document functionality should be working as expected.
Posted May 15, 2023 - 18:09 UTC
Monitoring
Docusign is implementing a fix. We are seeing some success but are continuing to monitor. We will notify once we have received word from Docusign regarding a full resolution.
Posted May 15, 2023 - 17:35 UTC
Identified
DocuSign is currently experiencing an outage. Any documents, follow-ups, disclosures, or closings using DocuSign will not be able to be completed and retrieved until the outage is resolved.
Posted May 15, 2023 - 16:30 UTC
This incident affected: Lending Platform.