SMS provider Outage potentially impacting MFA authentication messages

Incident Report for Blend

Resolved

We will continue to monitor SMS deliverability.
Posted Aug 28, 2025 - 20:56 UTC

Monitoring

Blend has been made aware of an outage impacting the SMS provider that may prevent certain MFA authentication codes from being delivered to the intended recipients.

Twilio is aware of this issue and continues to monitor this incident via their status page: https://status.twilio.com/incidents/xyn0p43sjdq5

Blend will continue to monitor this incident as well and will update its status page as soon as updates become available.

In the meantime, please don't hesitate to reach back with any additional question, suggestion or update to support@blend.com
Lending Platform
Posted Aug 28, 2025 - 19:12 UTC

Investigating

Blend has been made aware of an outage impacting the SMS provider that may prevent certain MFA authentication codes from being delivered to the intended recipients.

Twilio is aware of this issue and continues to monitor this incident via their status page: https://status.twilio.com/incidents/xyn0p43sjdq5

Blend will continue to monitor this incident as well and will update its status page as soon as updates become available.

In the meantime, please don't hesitate to reach back with any additional question, suggestion or update to support@blend.com
Posted Aug 28, 2025 - 19:12 UTC
This incident affected: Lending Platform.