CLOSING - Users may be experiencing troubles sending closing Packages to Blend

Incident Report for Blend

Resolved

The fix for this issue has now been deployed, and we believe the matter is fully resolved.
Posted Jul 22, 2026 - 21:09 UTC

Monitoring

We have identified an issue impacting the ability to send closing packages. A fix has been deployed, and we are actively monitoring the system to confirm that sending functionality has been fully restored. We will provide another update once the issue is fully resolved
Posted Jul 22, 2026 - 17:52 UTC

Investigating

We are currently investigating an issue where users may be unable to send closing packages to Blend.
Our team is actively working to identify the root cause and restore normal functionality as quickly as possible.
We will continue to monitor the situation closely and provide further updates as more information becomes available.
Posted Jul 22, 2026 - 16:38 UTC
This incident affected: Blend Close.