eSign task not released
Incident Report for Blend
Resolved
We have identified and remedied an issue for specific Encompass LOS customers that have recently opted-in to a new version of the SSA-89 form generated by EllieDocs.
Posted Jan 13, 2023 - 22:36 UTC
Update
We are continuing to investigate this issue.
Posted Jan 13, 2023 - 20:08 UTC
Investigating
We are aware of a small number of loans whose eSign task was not released, though it should have been. We are actively investigating this issue and will provide updates as we learn more.
Posted Jan 13, 2023 - 20:07 UTC
This incident affected: Lending Platform.