Pipeline Delay and Services

Incident Report for Blend

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 11:09 UTC

Monitoring

During approximately between 8pm PT and 10pm PT, an issue occurred within Blend’s internal event system, causing delays in new application data showing up in the Pipeline and other services. The team has restored the system and is assessing any further impact.
Posted Mar 26, 2025 - 05:59 UTC