Ticket Delivery Delays

Incident Report for Blend

Monitoring

We are seeing signs of recovery, and tickets are beginning to flow into our system again. We are cautiously optimistic that service is being restored, but we are continuing to monitor closely.

Earlier today, an issue impacting email delivery to our ticketing system prevented some messages from being successfully converted into tickets. At this time, we cannot guarantee that all communications sent via email were received or processed.

Action required:

Please review any requests or updates you sent today and resend them to ensure we have received and can act on them.

As a reminder, our chat support has remained fully operational throughout this incident and is always available if you need immediate assistance.

We appreciate your diligence and patience while we work to confirm full resolution and will continue to provide updates as we validate stability.
Posted Apr 08, 2026 - 21:36 UTC

Identified

We are currently experiencing delays in receiving support tickets due to an issue with our ticketing system provider.

The root cause has been identified as an ongoing infrastructure issue impacting Freshdesk’s mail servers, which is preventing some emails from being successfully delivered into our system. As a result, tickets sent via email may be delayed or not received.

Additionally, Microsoft is currently experiencing a broader service outage, which may also be contributing to the issue. Investigations are still ongoing to fully understand the impact.

Recommended action:
If you need immediate assistance, please reach out to our Support team via chat to ensure your request is received.

We are actively working with our partners and will continue to share updates as more information becomes available.
Posted Apr 08, 2026 - 18:22 UTC

Investigating

We are currently experiencing delays in receiving support tickets due to an issue with our ticketing system provider.

The root cause has been identified as an ongoing infrastructure issue impacting Freshdesk’s mail servers, which is preventing some emails from being successfully delivered into our system. As a result, tickets sent via email may be delayed or not received.

Additionally, Microsoft is currently experiencing a broader service outage, which may also be contributing to the issue. Investigations are still ongoing to fully understand the impact.

Recommended action:
If you need immediate assistance, please reach out to our Support team via chat to ensure your request is received.

We are actively working with our partners and will continue to share updates as more information becomes available.
Posted Apr 08, 2026 - 16:54 UTC