Encompass (ICE) Degraded Performance

Incident Report for Blend

Resolved

Encompass confirmed the issue on their end has been resolved and all services remain in a stable state.
Posted Apr 25, 2026 - 13:49 UTC

Monitoring

Encompass updated their status indicating that they are now seeing high success rates across all production user connections. They will be continuing their efforts for complete stabilization.
Posted Apr 24, 2026 - 18:56 UTC

Identified

We have been made aware of an Encompass outage that may be affecting exports, disclosure and document sync.
Please visit the ICE status page for the latest updates: https://www.ice.com/status#mortgage-technology.
Posted Apr 24, 2026 - 16:21 UTC
This incident affected: Lending Platform, LOS Integrations, and Disclosures and Documents.