Application Export latency (stuck) incident

Incident Report for Blend

Resolved

We have identified the impacted applications and re-exported applications stuck "in progress." We have started sending out impact lists individually to any impacted clients.
Posted Nov 25, 2025 - 21:02 UTC

Monitoring

Blend has been made aware of an issue that may have impacted application exports where applications may have been left in "in progress" export status as a result of a temporary issue that has since been resolved.

Blend is working to identify a list of potentially impacted applications apply the respective corrections. We will continue to monitor for updates and relay them as soon as they become available.

In the meantime, please don't hesitate to reach back with any additional question to support@blend.com
Posted Nov 25, 2025 - 16:40 UTC
This incident affected: LOS Integrations.