We have received confirmation from ICE at approximately 3:30 PM PST that they are no longer experiencing the error that occurred this morning.
Salesforce (MuleSoft) support has confirmed a platform-wide service disruption on their end. The Blend Engineering team is actively engaged with Salesforce Support to prioritize and accelerate a resolution specifically for our integration pathways.
We are closely monitoring the situation and will provide further updates as the joint remediation efforts progress.
Posted Jun 05, 2026 - 23:22 UTC
Update
Current Status: We have confirmed with ICE (Encompass) that the ongoing connectivity issue is intermittent. As a result, some disclosures are successfully routing to borrowers, while others may experience failures or delays. Please make a retry attempt if you see a failure with the issue being intermittent the retry may allow the package to be delivered.
Technical Update: Salesforce (MuleSoft) support has confirmed a platform-wide service disruption on their end. The Blend Engineering team is actively engaged on a live call with Salesforce Support to prioritize and accelerate a resolution specifically for our integration pathways.
We are closely monitoring the situation and will provide further updates as the joint remediation efforts progress.
Posted Jun 05, 2026 - 20:57 UTC
Identified
We are currently experiencing connectivity issues affecting the integration between Encompass and Blend, which is impacting the processing of disclosures.
Preliminary investigation indicates this is due to a service degradation on our MuleSoft Middleware Platform (hosted by Salesforce). Our Engineering team is actively investigating the root cause and working toward a resolution.
We apologize for any inconvenience this may cause and will provide further updates as new information becomes available.
Posted Jun 05, 2026 - 19:11 UTC
This incident affects: LOS Integrations and Disclosures and Documents.